הפעלת והגדרת רכיב רשת אמיתי – סוויץ' 2960 – Cisco Switch 2960 – אתר מגמת תקשוב – Tikshuv-CCNA

הפעלת והגדרת רכיב רשת אמיתי – סוויץ' 2960 – Cisco Switch 2960

Real_switch_config

במקצוע תקשוב או CCNA אנו לא אמורים רק ללמוד תיאוריה ואיך הדברים עובדים, אלא ממש לגרום לדברים לקרות – ממש להגדיר את ציוד הרשת. אז אנו במגמה עובדים עם ציוד של סיסקו, ולכן לרוב עובדים עם תוכנת הסימולציה Packet Tracer (פאקט טרייסר) – שזו תוכנה מעולה, שקל לעבוד איתה, ולראות איך התקשורת עוברת ברשת.
אך מה לעשות, העולם האמיתי שונה מאוד מעולם הסימולציה. – בעולם האמיתי יש רכיבים פיזיים אמיתיים ולא רק ציורים ותוכנות.

חובה עלינו לראות, להתיידד ואף להגדיר גם ציוד אמיתי. עלינו לחוש את הציוד ולהצליח בעולם האמיתי. מלבד זאת, חלק מתוכנית הלימודים דורשת ידע בסיסי בעבודה על ציוד אמיתי. יותר מכך, הבוחן שמגיע לבחון את תלמידי הפרויקט ברשתות בכיתה י"ב עלול לבקש מהתלמיד להתחבר לסוויץ' ולהתחיל להגדירו.
לכן בשורות אלו, אסביר:

  • על סוויץ' של סיסקו 2960 – איך הוא נראה באמת ואיך חיבוריו נראים?
  • כיצד מפעילים את הסוויץ' וכיצד מחברים אותו למחשב?
  • כיצד אנו נכנסים למצב הגדרה של הסוויץ' במחשב?
  • כיצד אנו מגדירים בפועל את הסוויץ'?

היכרות עם הסוויץ' (Switch), פורטים, חיבורים וכבלים

אנו נדגים על Cisco Swtich מדגם 2960, לסוויץ שבידנו יש 24 פורטים (Ports) במהירות של 100Mb/s, 2 פורטים במהירות של 1000Mb/s = 1Gb/s. תומך במצב Full Duplex (תקשורת דו-כיוונית), ויש לו גם Auto MDI/X (מהפך כבלים).
חשמל מקבל משקע בקיר (240V), בעל כניסת Console עם חיבור כבל RollOver.
מכיון שבידנו כבל Serial – RollOver נחבר מתאם מ- Serial ל- USB.

הסבר מצולם – שלב 1 – הכרה עם הסוויץ':

 

תמונות המתארות את הסוויץ' ואת הרכיבים השונים:

הכנה לקראת התחברות למחשב וניהול הסוויץ'

עכשיו נמשיך בשלבים אלו:

  1. נחבר את הסוויץ' לחשמל, נשמע את המאווררים מתחילים להרעיש. ולפני שמחברים את הסוויץ' למחשב, עלינו להתקין דרייברים מתאימים, על מנת שהסוויץ' יזוהה במחשב.
    ייתכן שכאשר נחבר את כבל הסריאלי \ USB למחשב, מערכת ההפעלה באופן אוטומטי תתקין את הדרייבר המתאים, אם לא, נתקין ידנית.
    ניתן להוריד את הדרייבר הנדרש מפה: דרייבר עבור מחבר USB-SERIAL. לאחר ההורדה יש להתקינו.
  2. כעת ניכנס ל"מנהל ההתקנים" (או Device Manager) בווינדוס על מנת לגלות באיזה חיבור סריאלי לוגי אנו משתמשים (COM), אנו נראה משהו כזה:נא לזכור את מספר ה- COM, נצטרך אותו לאחר כך.
  3. עכשיו נוריד תוכנה ששמה putty: קישור להורדת התוכנה putty. [מומלץ להוריד את הגרסא הניידת – portable ללא צורך בהתקנה – נמצאת תחת הכותרת: "putty.exe (the SSH and Telnet client itself)"].

    downloading_putty_official

    כך מורידים את תוכנת putty

putty_main_window

כך נראה החלון הראשי של תוכנת putty לאחר הפעלת התוכנה

בשלב זה הסוויץ' מחובר לחשמל ועובד, כבל הסריאל מחובר למחשב, התקנו דרייבר על מנת לזהות אותו במחשב והתקנו את תוכנת ה- Putty על מנת להתחבר בחיבור סריאלי ולהגדיר את הסוויץ'.

הסבר מצולם – שלב 2 – הכנה לקראת התחברות למחשב וניהול הסוויץ':

התחברות לניהול הסוויץ' באמצעות כבל קונסול – חיבור ישיר והגדרות ראשוניות

הסבר מצולם – שלב 3 – התחברות לניהול באמצעות קונסול והגדרות ראשוניות:

אנו מחוברים לסוויץ', ותוכנת ה- putty שלנו פתוחה, כדי שנוכל להתחיל ולשלוח הגדרות לניהול הסוויץ' עלינו לסדר מעט את ההגדרות של התוכנה.
נכנסים בצד שמאל למטה בסוף ל- "Serial", יש להכניס את מספר ה- COM שגילינו בשלב הקודם (אם לא זוכרים, יש להיכנס שוב ל"מנהל ההתקנים" (Device Manager) ולראות איזה COM זה), ולבסוף למטה ב- "Flow Control" להעביר למצב "None".

setting_settings_for_serial_in_putty

כך יש להגדיר את ההגדרות על מנת שנוכל להתחבר באמצעות חיבור סריאלי

עכשיו חוזרים למסך הראשי, לוחצים בצד שמאל למעלה על: "Session", מעבירים למעלה לחיבור מסוג "Serial" ופותחים חיבור למטה ב- "Open".

Starting Connection Serial

בחירת חיבור Serial והפעלת חיבור

הגענו למסך המוכר מה- Packet Tracer, מכאן אנו "בבית", זה ממש דומה לפאקט טרייסר (יותר נכון – פאקט טרייסר ממש דומה לזה), רק שפה יש הרבה יותר פקודות, ודברים הולכים מעט יותר לאט. כמו כן אם עושים כאן טעות משלמים עליה :)… אי אפשר לזרוק את הסוויץ' ולהביא חדש כמו בפאקט טרייסר (אלא אם יש לכם כמה אלפים מיותרים).
לעבוד בצורה מסודרת, לאט, לחשוב מה עושים – לא לעשות שטויות.

אנו נגדיר הגדרות בסיסיות, ראשית נגדיר שם לסוויץ' (hostname):

Switch>enable
Switch#configure terminal
Switch#hostname Real-SW

כעת נגדיר ססמאות למצב enable ולהתחברות דרך קונסול (מה שאנו עושים כעת – מחוברים בקונסול) – כלומר אם נצא וניכנס נידרש להכניס ססמא:

Real-SW(config)#enable password 1234
Real-SW(config)#line console 0
Real-SW(config-line)#password 1234
Real-SW(config-line)#login

אם אנו כבר כאן נגדיר גם ססמא למצב התחברות מרוחקVTY – ונראה את היישום כאשר נתחבר עם כבל רשת בהמשך:

Real-SW(config)#line vty 0 4
Real-SW(config-line)#password 1234
Real-SW(config-line)#login

נגדיר באנר כניסה:

Real-SW(config)#banner motd $ This is THE REAL WORLD $

כעת אפשר להגדיר מה שאנו רוצים כמו שאנו מגדירים בתוכנת ה- Packet Tracer.
נכון לעכשיו כל הפורטים משוייכים ל- VLAN ברירת מחדל (Default Vlan) כלומר Vlan 1. נניח שנרצה לשנות זאת.
למשל פורטים fa0/1-2 יהיו ב- Vlan 10 (ששמו יהיה new) ואילו פורטים fa0/3-4 יהיו ב- Vlan 20 (ששמו יהיה new2):

Real-SW(config)#vlan 10
Real-SW(config-vlan)#name new
Real-SW(config)#vlan 20
Real-SW(config-vlan)#name new2

Real-SW(config)#interface range fa0/1-2
Real-SW(config-if-range)#switchport access vlan 10
Real-SW(config)#interface range fa0/3-4
Real-SW(config-if-range)#switchport access vlan 20

כעת פורטים fa0/1-2 נמצאים ברשת הוירטואלית vlan 10 ואילו פורטים fa0/3-4 נמצאים ברשת הוירטואלית vlan 20 ולא יוכלו לדבר זה עם זה.
אנו יכולים ממש לחבר מחשבים לפורטים אלו – על אמת! ולראות זאת – הם לא יוכלו לתקשר.

כמו פקודות אלו, אפשר להציג כמובן את כל פקודות ה- show לדוגמא: show vlan, show ip interface brief, show running-config.
צריך לציין שאם ננתק את הסוויץ' מהחשמל ונתחבר בשנית כמעט כל ההגדרות שהגדרנו יימחקו! – שם הסוויץ', הגדרות הססמאות ועוד. – אם ברצוננו שזה לא יקרה עלינו לכתוב את הפקודה:

Real-SW#copy running-config startup-config

פקודה זו אומרת לסוויץ' לשמור את ההגדרות ששמורות כעת בזכרון הזמני RAM להעביר אותן ל- NVRAM ובכך הן יישמרו ויעלו עם הסוויץ' בפעם הבאה.
אני חייב להזהיר! – צריך מאוד מאוד להיזהר! לא בהכרח כדאי לשמור כל הזמן שעובדים עם ציוד אמיתי ואנחנו בתנאי מעבדה, במידה ותלמיד או מורה יגדיר ססמא, ואנו לא זוכרים אותה, נצטרך כל פעם לאפס את הגדרות הסוויץ' וזה מסבך את העניינים – נא להיזהר! אולי עדיף לא לשמור.

עד כאן הגדרנו באמצעות חיבור ישיר – Console – חיבור Serial. כעת ננסה חיבור מרוחק = חיבור וירטואלי – VTY.

התחברות והגדרות על ידי גישה וירטואלית – Telnet

בעולם האמיתי, אולי בהתחלה נבוא עם כבל פיזי ישיר (כבל סריאלי) נתחבר לחיבור ה- Console ונתחיל להגדיר, אבל תארו לכם שבכל פעם שצריך לבצע משהו, צריך ממש לבוא פיזית לרכיב ולהגדיר אותו – הזוי! לכן הומצא החיבור הוירטואלי – VTY – Virtual Line – מה שחיבור זה עושה, הוא מאפשר לשלוח הגדרות על גבי הרשת – על גבי כבלי רשת רגילים, ללא צורך בהתחברות ישירה.
כל עוד הסוויץ' נמצא ברשת יהיה ניתן להגדירו.

הסבר מצולם שלב 4 – התחברות והגדרות על ידי גישה וירטואלית – Telnet:

כדי לבצע זאת, ראשית עלינו להגדיר כתובת IP לסוויץ', כתובת IP ל- ממשק וירטואלי של VLAN.
אז אנו ממשיכים בהגדרות על ידי חיבור הקונסול, להזכירכם הגדרנו את fa0/1-2 על vlan 10 ואת fa0/3-4 על vlan 20. אז אם נניח אנו רוצים לנהל את הסוויץ' באמצעות vlan 10, אנו נגדיר את הממשק הוירטואלי vlan 10 וניתן לו כתובת IP:

Real-SW>enable
Real-SW#configure terminal
Real-SW(config)#interface vlan 10
Real-SW(config-if)#ip address 192.168.1.1  255.255.255.0

במידה ואתם רוצים גם להכניס אחר כך ראוטר שינתב, צריך להגדיר ניתוב ברירת מחדל:

Real-SW(config)# ip default-gateway 192.168.1.254

זהו לשלב זה.
כעת אפשר לנתק את כבל ה- Console שלנו (לא לנתק את כבל החשמל – לא לכבות את הסוויץ'!).
ונחבר כבל רשת מהמחשב שלנו לסוויץ' לפורט fa0/1 (או fa0/2).
ראשית יש להגדיר את כתובת האייפי של המחשב שאיתו מתחברים לסוויץ' כך שיהיה באותה הרשת, למשל להגדיר את כתובת האייפי כ- 192.168.1.2 255.255.255.0.
כדי להגדיר את כתובת האייפי ניתן להשתמש בפקודת ה- netsh בשורת הפקודה (CMD) או באמצעות הממשק הגרפי של ווינדוס ב- "‏‏לוח הבקרה\‏‏רשת ואינטרנט\חיבורי רשת", שם כפתור ימין על חיבור הרשת הקווי (חיבור Ethernet), לאחר מכן יש לבחור "מאפיינים" (Prefences), וכניסה ל- "פרוטקול אינטרנט גרסא 4" (TCP/IP IP version 4):

enter_ipv4_change_windows

כך נכנסים להגדרות שינוי IP בווינדוס

לאחר מכן בחלון הבא ניתן להגדיר כתובת IP סטטית, בדוגמא הגדרנו: 192.168.1.2 מסכת רשת: 255.255.255.0, שער ברירת מחדל (Default Gateway) נצרך רק אם אנו מוסיפים גם ראוטר לטופולוגיה.

put_static_ips_in_windows

כך מגדירים כתובת אייפי סטטית בווינדוס

לאחר הגדרות אלו, אנו חוזרים אל Putty, וכעת במסך הראשי אנו בוחרים ב- Telnet, ומכניסים את כתובת האייפי של הסוויץ' שהגדרנו: 192.168.1.1 ולוחצים open לתחילת ההתחברות:

connecting_telnet_using_putty

כך מתחברים להגדרת הסוויץ' בהתחברות מרוחקת וירטואלית מסוג telnet

זהו כעת אנו מחוברים למסך הידוע, והסיפור דומה להתחברות ב- console, רק שכעת לא חייבים להיות ליד הסוויץ' יכולים להיות במרחק של עשרות ומאות מטרים ממנו ואפילו יותר – כל עוד אנו יכולים לגשת אליו ברשת – לעשות אליו Ping אנו נוכל גם להגדיר אותו.

בזה נחתמה ההיכרות שלנו עם סוויץ' אמיתי והגדרות בסיסיות בו.

כמובן מכאן, אפשר להגדיר באותה צורך ראוטר (Router), וכן לשלב בין סוויצ'ים וראוטרים – והשמים הם הגבול.

האם יש לכם מה להוסיף? איך התלמידים מגיבים לעבודה על רכיבים אמיתיים בהשוואה לפאקט טרייסר?

אולי תאהבו גם...

2 תגובות

  1. אברהם הגיב:

    אם אני רוצה, איך אני מכבה את הswitch יש לזה פקודה או משהו?

    • שלום אברהם
      על מנת לכבות פורטים (שקעים – ממשקים) בסוויץ' עליך לבחור את הממשק ולבצע shutdown למשל על מנת לכבות את פורט fa0/1 עליך לבצע:
      enable
      configure terminal
      interface fa0/1
      shutdown
      וכן אותו הדבר עבור הפורטים האחרים

      בהצלחה!

כתיבת תגובה

האימייל לא יוצג באתר. שדות החובה מסומנים *